Afret

Disponible uniquement sur Etudier
  • Pages : 4 (892 mots )
  • Téléchargement(s) : 0
  • Publié le : 30 avril 2010
Lire le document complet
Aperçu du document
TP n°15 ASSOCIATIONS DE PORTES LOGIQUES

Objectifs :

- Construire la table de vérité d’une fonction logique à l’aide d’un tableur.
- Réaliser des fonctionslogiques à l’aide de la porte NON ET.
- Réaliser des mémoires grâce à la logique séquentielle.

I – Logique et tableur

Un tableur est capable de gérer des fonctions mathématiques classiques,mais aussi des fonctions logiques.

• Lancer le logiciel tableur et préparer un tableau comme suit : les deux premières colonnes A et B représentent les variables, c’est-à-dire les états que l’onimpose aux entrées A et B de la porte logique.

| |A |B |C |D |
|1|A |B | |S |
|2 |0 |0 || |
|3 |0 |1 | | |
|4|1 |0 | | |
|5 |1 |1 || |

• La troisième colonne donnera le résultat de l’opération logique “ET” par exemple. Pour cela rentrer dans la case C2 : =ET(A2 ; B2) puiscopier vers le bas.

• Pour convertir le résultat VRAI ou FAUX en un état logique 1 ou 0, utiliser la fonction SI en rentrant dans la cellule D2 : =SI(C2=VRAI ;1 ;0).
Le logicielva alors traduire tous les « VRAI » par « 1 » et tous les « FAUX » par « 0 ». Recopier vers le bas.

• Vérifier que l’on obtient bien la table de vérité de la porte « ET ».

• Faire de...
tracking img