Tutoriel Fonction RECHERCHEV

Marche à suivre RECHERCHEV (Excel 2003 & Excel 2007)
Les références
* Vous devez sélectionner les références dans votre tableau. Dans cet exemple votreréférence est $A$2:$D$10. Une fois votre sélection faite vous cliquez sur Insertion - Nom - Définir (Pour l'exemple ici j'ai donné le nom CHAMPS).

Excel 2007: La définition du nom se fait via le menuFormules.
Emplacement où les données trouvées vont apparaitre
* Dans cet exemple:
* H1=Terme à rechercher
* H4=Description trouvée (colonne2 de notre tableau)
* H6=Quantitétrouvée (colonne 3 de notre tableau)
* H8=Prix trouvé (colonne 4 de notre tableau)

Les formules

La syntaxe de base de la fonction RECHERCHEV est:=RECHERCHEV(valeur_recherchée;table_matrice;no_index_col;valeur_proche)
* H4
* =RECHERCHEV($H$1;CHAMPS;2;FAUX)
* En clair, on part du contenu de la cellule H1, on cherche dans la première colonne du tableau CHAMPSla ligne commençant par ce contenu, et on extrait la valeur placée dans la deuxième colonne ; FAUX indique que l'on recherche une correspondance exacte.
* Pour éviter d'avoir un message #N/Asi rien n'est trouvé on utilise la formule suivante et "Inconnu" apparaîtra dans la cellule de résultat.
*=SI(ESTNA(RECHERCHEV($H$1;CHAMPS;2;FAUX));"Inconnu";RECHERCHEV($H$1;CHAMPS;2;FAUX))
* Avec Excel 2007 une formule plus courte existe: =SIERREUR(RECHERCHEV($H$1;CHAMPS;2;FAUX);"Inconnu")
* H6
* =RECHERCHEV($H$1;CHAMPS;3;FAUX)
* En clair, on part ducontenu de la cellule H1, on cherche dans la première colonne du tableau CHAMPS la ligne commençant par ce contenu, et on extrait la valeur placée dans la troisième colonne ; FAUX indique que l'onrecherche une correspondance exacte.
* Pour éviter d'avoir un message #N/A si rien n'est trouvé on utilise la formule suivante et "Inconnu" apparaîtra dans la cellule de résultat.
*... [à continuer]

Lire la dissertation complète

Citer cette dissertation

APA

(2011, 05). Comment elaborer une facture sur exel. Etudier.com. Récupérée 05, 2011, à partir de http://www.etudier.com/dissertations/Comment-Elaborer-Une-Facture-Sur-Exel/272022.html

MLA

"Comment elaborer une facture sur exel" Etudier.com. 05 2011. 2011. 05 2011 <http://www.etudier.com/dissertations/Comment-Elaborer-Une-Facture-Sur-Exel/272022.html>.

MLA 7

"Comment elaborer une facture sur exel." Etudier.com. Etudier.com, 05 2011. Web. 05 2011. <http://www.etudier.com/dissertations/Comment-Elaborer-Une-Facture-Sur-Exel/272022.html>.

CHICAGO

"Comment elaborer une facture sur exel." Etudier.com. 05, 2011. Accédée 05, 2011. http://www.etudier.com/dissertations/Comment-Elaborer-Une-Facture-Sur-Exel/272022.html.