Fonction si

Disponible uniquement sur Etudier
  • Pages : 5 (1099 mots )
  • Téléchargement(s) : 0
  • Publié le : 28 avril 2011
Lire le document complet
Aperçu du document
La fonction SI().

Présentation

Cette fonction permet de renvoyer deux résultats différents selon un certain critère, une certaine condition.
Cette fonction possède donc trois paramètres (arguments). Le premier représente le critère, le second le résultat si la condition est vérifiée, et le troisième la valeur dans le cas contraire. Nous obtenons donc la fonction :SI(critère ; valeur_si_vrai ; valeur_si_faux).
Cette fonction SI doit toujours être associée avec la phrase suivante : si "critère", alors "valeur_si_vrai", sinon "valeur_si_faux".
Pour bien être à l’aise avec cette fonction, il faut souvent essayer de la traduire en français.

Les critères
Un critère peut être un nombre, une référence de cellule, une chaîne de texte , ouencore une expression. Les expressions et les chaînes de texte sont mises entre guillemets.
Voici quelques exemples :
- Nombre : 12, 7,2%,…
- Référence de cellule : E8, $E42,…
- Chaîne de texte : "ESCC 2000", "mot",…
- Expression : ">=2010", "1,23",…
[pic]
Remarques : Les critères ne tiennent pas compte de la casse, c’est-à-dire des majuscules ouminuscules. Ainsi, les chaînes "dormir" et "DORMIR" donneront le même résultat.
Il est possible d’utiliser les caractères génériques ' ?' et '*' dans les critères. Le point d’interrogation correspond à un caractère quelconque et l’astérisque correspond à une séquence de caractères quelconque. Pour rechercher explicitement un point d’interrogation ou un astérisque, il faut le faire précéder ducaractère tilde '~'.
Voici quelques exemples :

|Critère |Description |
| "*" |Correspond aux cellules contenant du texte. |
|" ?"|Correspond aux cellules contenant un seul caractère. |
|"semaine *" |Correspond aux cellules dont la valeur commence par la chaîne "semaine " (attention au caractère espace). |
|"sem*" |Correspond aux cellules dont la valeur commence par la chaîne "sem". ||"???s" |Correspond aux cellules dont la valeur commence par 3 caractères quelconques et termine par la chaîne "s". |
|"*semaine*" |Correspond aux cellules contenant la chaîne "semaine". |
|""&"*semaine*" |Correspond aux cellules ne contenant pas la chaîne "semaine".|
|>"&E18 |Correspond aux cellules dont la valeur est supérieure à la valeur de la cellule E18. |
| "~*" |Correspond aux cellules dont la valeur est le caractère '*'. |

Attention : Bien faire attention à l’utilisation desguillemets. Il faut les utiliser à bon escient et avec précision. Uniquement pour les chaînes de texte et les expressions.
[pic]
Les possibilités sont donc très nombreuses dès lors que l’on combine les caractères génériques entre eux.

Utilisation

Exemple 1 :
Soit la cellule A8 contenant une année.
La formule permettant de vérifier qu’A8correspond à l’année 1998 est :
=SI(A8=1998 ; "vrai" ; "faux").
← La formule vérifie si la cellule A8 a pour valeur 1998, et inscrit dans la cellule contenant la formule le texte "vrai" dans ce cas, et "faux" sinon.
La formule se traduit ainsi : si A8 est égale à 1998, alors entrer "vrai" dans la cellule résultat, sinon, entrer "faux" dans la cellule résultat, la cellule...
tracking img