Joey107

265 mots 2 pages
Excel la fonction SOMMEPROD

un exemple

Un restaurateur possède deux établissements de fastes foudes, situés à Orléans et à Blois.

Chaque restaurant vend des sandwichs et des salades.

Les statistiques des ventes de ces deux restaurants pour les quatre premiers mois de l'année 2009 sont présentées ci-contre.

Le restaurateur souhaite obtenir pour chaque mois le chiffre d'affaires total de ses deux restaurants

note : les résultats ne sont donnés ici qu'à titre de vérification, puisque nous allons les calculer.

fonction SOMMEPROD

La fonction SOMMEPROD permet d'effectuer horizontalement le produit de deux valeurs situées dans des colonnes différentes et d'en additionner les résultats. Par exemple, pour le mois 1, le chiffre d'affaires total des deux restaurants se calcule de la façon suivante : (850x3)+(700x2)+(880x3)+((780x2) = 8 150.
La fonction SOMMEPROD effectue donc, ligne à ligne, la somme de produits.
Nous aurons donc la formule suivante : I5 = SOMMEPROD(E2:E5;F2:F5)

Cette formule effectue le calcul suivant : (E2*F2)+(E3*F3)+(E4*F4)+(E5*F5)

fonction SOMMEPROD et conditions

La fonction SOMMEPROD peut être assortie de conditions.

Si l'on veut la vente totale de salades à Orléans en 2009, la formule sera :

=SOMMEPROD((A2:A17=2009)*(C2:C17="Orléans")*(D2:D17="salade")*(E2:E17)*(F2:F17))

Si l'on veut le nombre de ventes de sandwichs à Blois en 2009, la formule sera :

=SOMMEPROD((A2:A17=2009)*(C2:C17="Blois")*(D2:D17)="sandwich"))

Si l'on veut le nombre de ventes dont le montant est supérieur à 2 000 €, la formule sera :

en relation