pascal

Pages: 4 (813 mots) Publié le: 9 décembre 2014


I. Forme Réduite :
Activité :
Ecrire un programme qui permet à l’utilisateur d’entrer un entier n et d’afficher s’il est pair ou impair.
Pour répondre à un tel problème il faut passer par untest qui permet la vérification de la condition.
Ce test peut être exécuté grâce à une structure appelée « la structure de contrôle conditionnelle ».
Vocabulaire :



Analyse
AlgorithmeNom= parité
Résultat = Ecrire (MSG)
MSG=[ ] Si N mod 2 = 0
Alors MSG ß ‘’pair’’
Fin Si
Si N mod 2 =1
Alors MSG ß ‘’impair’’Fin Si
N=donnée
Fin Parité
0) Début Parité
1) Lire (N)
2) Si N mod 2 = 0
Alors MSG ß ‘’pair’’
Fin Si
3) Si N mod 2 =1
AlorsMSG ß ‘’impair’’
Fin Si
4) Ecrire (MSG)
5) Fin Parité

Objet
Type
Rôle
N
Entier
Donnée
MSG
Chaine de caractères
Message à afficher

Pascal :
program parite;uses wincrt;
var
n:integer;
msg:string;
begin
readln(n);
if n mod 2 = 0 then msg:='pair';
if n mod 2 = 1 then msg:='impair';
writeln(msg);
end.
Application 1 :
Ecrire un programme quipermet à l’utilisateur d’entrer une chaine de caractère de longueur impair et ≥ 3, (sinon on affiche un message d’erreur.) puis d’afficher le caractère de milieu.

Analyse
Algorithme
Nom=application1
Résultat = Ecrire (MSG)
MSG=[ ] Si(long(ch)≥3) et (long(ch) mod 2 =1)
Alors MSG ß ch[(long(ch)div2)+1]
Fin Si
Si(long(ch)2 alorsmsgß’’suffisant’’
Sinon
msgß’’Insuffisant’’
Fin Si
E=donnée
Fin espace
0) début espace
1) Lire ( e )
2) Si e > 2 Alors
msgß ‘’suffisant’’
Sinon
Msgß‘’insuffisant’’
Fin si
3) Ecrire (msg)
4)Fin espace
Program espace;
Uses wincrt;
Var
E : real;
Msg: string;
Begin
Readln ( e );
If e > 2 then msg:=‘suffisant’
Else
Msg:=‘insuffisant’;...
Lire le document complet

Veuillez vous inscrire pour avoir accès au document.

Vous pouvez également trouver ces documents utiles

  • Pascal
  • Moi
  • Pascal
  • pascal
  • Pascal
  • Pascal
  • Pascal
  • Pascal

Devenez membre d'Etudier

Inscrivez-vous
c'est gratuit !