VB.net

Pages: 5 (1009 mots) Publié le: 4 janvier 2015
ISN

VB.Net - 06 - Les boucles.docx
Les activités portent sur la gestion des boucles, 2 possibilités :



L’itération et le bouclage sont gérés par le programme ;
L’itération est gérée par le programme, le bouclage par l’utilisateur.

Des activités pour appréhender le passage de l’algorithme à la programmation et s’entrainer à la
programmation en VB.Net. Le besoin, l’algorithme etl’interface sont donnés.
Remarque : Les messages d’introduction dans les interfaces ne sont pas indiqués dans les algorithmes.

I. Activité Un nombre particulier
I.1. Le besoin
Un seul nombre entier est compris entre un carré et un cube de nombres entiers, lequel ?
Avec X l’inconnu, on peut écrire : A2 < X < B3 avec B3 = A2 + 2 = X + 1 ; A, X, B entiers.
I.2. L’algorithme
L’algorithme effectuela vérification sur 10000 valeurs de A, cette itération peut être menée plus loin.
Variable B3 en entier
Variable B en décimal
Début
Pour A ← 1 à 10000
B3 ← A ^ 2 + 2
B ← B3 ^ (1 / 3)
Si Entier(B) = B Alors Ecrire "Le nombre est " & B3 – 1
Fin Pour
Fin

I.3. L’interface et le code
Ecrire le programme avec l’interface ci-contre et avec :
 Aucune donnée à saisir ;
 Une réponse dansle label Réponse après un clic sur Rechercher ;
 Le symbole ^ pour élever un nombre à la puissance indiquée.
Observer le résultat en fonction du type des variables B3 et B.

II. Activité La table de multiplication
II.1. Le besoin
Afficher la table de multiplication d’un chiffre saisi par l’utilisateur.
II.2. L’algorithme
Variable Table en Entier
Début
Lire Table
Ecrire "la table demultiplication de" & Table & " est :"
Pour Index ← 1 à 10
Ecrire à la ligne Index & " x " & table & " = " & Index * Table
Fin Pour
Fin

II.3. L’interface et le code
Ecrire le programme avec l’interface ci-contre. La variable Table prend la
valeur saisie dans la textbox de saisie.
Pour passer à la ligne dans un label ou une textbox, utiliser :
Affichage.Text = Affichage.Text &ControlChars.CrLf & …
Pascal ROGER

VB.Net - 06 - Les boucles.docx - Page 1/4

Mise à jour le 14/12/14

ISN

III. Activité La limite d’une série
III.1. Le besoin
Déterminer la limite d’une série convergente. Le calcul s’arrête lorsque le nième terme est inférieur à10-6.
III.2. L’algorithme


Hypothèse : La série étudiée est convergente. Le programme est écrit pour la série



4
x3

1Variable Somme en décimal ← 0
Variable Delta en décimal ← 0
Variable X en entier ← 0
Début
Répéter
X←X+1
Delta ← 4 / (X ^ 3)
Somme ← Somme + Delta
Tant que Abs(Delta) > 10-6
Ecrire "La limite cette série est " & Somme
Fin

III.3. L’interface et le code
Ecrire le programme avec l’interface ci-contre. La fonction Abs fait partie de la
classe Math qu’il faut importer. Mettre tout audébut du code : Imports System.Math
Compléments : Tester avec d’autres séries, Modifier les type de variables, Mettre
en forme le résultat avec 5 décimales

IV. Activité le palindrome
IV.1. Le besoin
Le texte saisi est-il un palindrome ?
Un palindrome est un texte pouvant se lire dans les 2 sens, exemple : Esope reste ici et se repose
IV.2. L’algorithme
Pour simplifier : Pas de ponctuationet pas d’accent dans le texte à vérifier.
2 étapes : Supprimer les espaces puis Vérifier le palindrome
Variable Palindrome en Caractères ← ""
Variable Demi, Nb_Char en Entier
Variable Erreur en Binaire ← Faux
Début
Lire Texte
Texte ← Majuscule(Texte)
Nb_Char ← longueur(Texte)
Pour Index ← 1 à Nb_Char
Si Caractères(Texte, Index, 1) " " Alors Palindrome = Palindrome & Caractères(Texte,Index, 1)
Fin Pour
Nb_Char ← Longueur(Palindrome)
Demi ← Entier(Nb_Char/2)
Pour Index ← 1 à Demi
Si Caractères(Palindrome, Index, 1) Caractères(Palindrome, Nb_Char – Index + 1, 1) alors Erreur = Vrai
Fin Pour
Si Erreur = Vrai Alors
Ecrire "Ce texte n’est pas un palindrome"
Sinon
Ecrire "Ce texte est un palindrome"
Fin Si
Fin
Pascal ROGER

VB.Net - 06 - Les boucles.docx - Page 2/4...
Lire le document complet

Veuillez vous inscrire pour avoir accès au document.

Vous pouvez également trouver ces documents utiles

  • Vb.net
  • Vb.net
  • Travail pratique vb.net
  • Gestion fichiers vb.net

Devenez membre d'Etudier

Inscrivez-vous
c'est gratuit !